Exoline:Trouble running under Windows 10


#1

I have followed the install instructions to get Python 2.7.13 installed - seems to run fine.
I followed instructions to install Exoline - and that seems to have run fine.

I have 2 files in C:\Python27\Scripts now:
exo
exoline

However, if I try to run them I am getting a module not found error for _curses

Has anyone seen this?

Am I missing an environment variable or path of some type?

I’ve tried to find a module called _curses and have not had any luck.

Any suggestion appreciated.

Thanks,
-james


#2

If I remember correctly curses is not supported on Windows.

Which Instructions did you follow to install Exoline?


#3

From these: https://github.com/exosite/exoline
However, I see that I might have jumped the gun and didn’t use the ones specific to Windows below there.

I used chocolatey to install Python27 latest, which also acquired pip for me.
Then I used the pip install (without sudo - ran it in an admin command prompt).

So, I think I see what I did wrong (and it looked suspicious when the end result was files without .exe nor .py file extensions).

Do you think I can get the right packages, or should I uninstall everything and follow the windows instructions that use win-pip or whatever?


#4

I think you are already on your way to fixing this. If python27 is working you probably won’t have to uninstall it, but I would uninstall everything else.

I would recommend installing pip-win and using it to install Exoline. The package hosted there should be a version that does not have curses implemented.


#5

Followed your suggestion, pip uninstall exoline seemed to work fine.

I then installed and used win-pip.

This seems to be a gui that simply ran the command line pip install exoline, which appears to have yielded the same results.

here’s the error I get when I try to run python exo:

C:\Python27\Scripts>python exo
Traceback (most recent call last):
  File "exo", line 77, in <module>
    import blessings
  File "C:\Python27\lib\site-packages\blessings\__init__.py", line 5, in <module>
    import curses
  File "C:\Python27\lib\curses\__init__.py", line 15, in <module>
    from _curses import *
ImportError: No module named _curses

C:\Python27\Scripts>

So I seem to be experiencing the same result.

In a little while I’ll have access to a Mac that might be a better way to go anyway.

Perhaps wait until I reply with an update before pursuing this further?

Thanks for your excellent help so far.

-james


#6

This might be a problem with the release of Exoline 0.10.0. Could you the 0.9.18 installer on the releases page?

You should have little difficulty getting Exoline running on a Mac or Linux machine. It was developed with those OSs in mind.

-Martin


#7

I used the windows install, and it works - short of one feature I expected: the path to exo.exe was not added to my path.

Perhaps I should post an issue somewhere, where should I post that?

(If I have time, i will do the exo setup on my mac and let you know in this thread how that goes).

Thanks again!


#8

Feel free to post an issue on the ‘Issues’ page of the repository: https://github.com/exosite/exoline/issues

Glad to hear it mostly worked.

Happy to help,
-Martin


#9

Turns out the install did add the exoline folder to the path - I just needed to start a new command prompt.