Installing Apps on Gateway Fails


#1

Installing Apps on the Gatewey Engine Fails with the following message

pi@raspberrypi:~ $ sudo gwe --set-debug-level DEBUG --install-apps Demo.v1.tar.gz 
Installing app(s): ['Demo.v1.tar.gz']
No handlers could be found for logger "GWE.instlr"
'Demo.v1.tar.gz': 'Executing installer. Something went wrong during installtion.'
Installation of app 'Demo.v1.tar.gz' FAILED: code: 1
pi@raspberrypi:~ $ 

I have not tried an OTA install yet since this seems easier.

How should I fix?

Thanks,
Sudeep.


#2

Sudeep,

Try this command and take a look at the output, it might give a better clue as to what’s wrong:

sudo gwe --set-debug-level DEBUG --check-tarball Demo.v1.tar.gz

#3

Where should I run this on the gateway or on the VM?

I did this on the VM before I copied the file over to the gateway, everything passed.

Is there a way I can set up supervisor to run this manually after I copy Python file I need into /usr/local/bin. Not sure where to put in the supervisor.conf


#4

You can run it on either the gateway where GWE is running (in this case your VM) or on a development machine. The command just takes a look at the structure of the app tarball and other things like file permissions, etc.

Yes, in order to get your app to automatically start on boot you have to provide a supervisor.conf file. Take a look at the docs here on supervisor.conf basics.

Are you saying that the app is passing the --check-tarball test and still won’t install? If that’s the case then I agree that the debug output from the --install-apps command is not very useful.

What version of GWE are you using?

Thanks!