Python version and dependencies


[Question asked via email]

I was going through the getting started guide and it shows that you need Python 2.7.9+.

The gateway I am currently using has python 2.7.3. Did you stay with 2.7.3? Or did you upgrade python? And if so how did you install it and its dependencies.


This is the area we receive the most questions about: installation.

The docs site says Python 2.7.9+ mainly because of out QA environment. I have seen an installation and runtime environment of GWE succeed before on 2.7.3, but this version of python is not tested with the same degree of scrutiny as 2.7.9. You can certainly try it out and, if it works, I’m fairly certain it will be fine.

Since you seem to be building your linux image yourself, there are other dependencies that GWE needs such as the json module and other modules that are generally considered to be in the standard canon of modules. If you see installation issues due to things like ImportError, you are likely just missing a module and need to add it to your linux image with your toolchain (bitbake, buildroot, yocto, etc.).



Will you be supporting different versions of Python going forward? What about Python3?


Hi @Martin,

I think adding support for Python3 would be a good idea since platforms like RPi and Beaglebone are coming with 2.7.9+ and 3.x.x, but we would have to be smart about which 3.x we would support - 3.1, 3.4, 3.5. My feeling is that 3.1 and 3.4 could/should be skipped and we just support 2.7.9+ and 3.5.

Do you have any ideas on this? Do you know of any gateway-centric software that would need features from 3.1 that aren’t supported in 3.5, for instance?



I can’t think of anything in older versions of Python 3 that are not around anymore, I just don’t know enough about those versions.

I would say skipping ahead to the latest version of 3 would be a good idea. Have you had a chance to see the changes in 3.6?

Installing Gateway Engine on a Wind River Linux Gateway