Unable to enable the lightbulb device using GIT Bash


#1

need help on to resolve the below issue
while enable the light bulb device with GIT bash

Murano Example Smart Lightbulb Device Simulator booting…
Product Id:
Device Identity: 000001
Product Unique Host: .m2.exosite.com

get stored CIK from non-volatile memory
Unable to read a stored CIK: [Errno 2] No such file or directory: '_000001_cik’
try to activate
Exception: [Errno 11004] getaddrinfo failed
starting main loop
Connection: Not Connected, Run Time: 2, Temperature: 70.0 F, Humidity: 50.0 %, Light State: 0
Exception: [Errno 11004] getaddrinfo failed
Connection: Not Connected, Run Time: 5, Temperature: 70.0 F, Humidity: 50.0 %, Light State: 0
Exception: [Errno 11004] getaddrinfo failed
Connection: Not Connected, Run Time: 9, Temperature: 70.0 F, Humidity: 50.0 %, Light State: 0
Exception: [Errno 11004] getaddrinfo failed
Connection: Not Connected, Run Time: 12, Temperature: 70.0 F, Humidity: 50.0 %, Light State: 0


#2

@aashrith

It looks like you didn’t configure your device simulator with a Product ID. Try running this code again with that additional input. HTTPlib won’t have a chance at resolving the invalid host .m2.exosite.com.

Just in case, you can find your Product ID on your Product info page.

Hopefully this helps,
-Martin


#3

Thanks for quick response Martin.
here i am passing like the product id:

$ python murano_device_simulator.py
Check for Device Parameters Enabled (hit return after each question)
Enter the Murano Product ID: r2c7s58btf3k00000
The Host Address is: r2c7s58btf3k00000.m2.exosite.com
The default Device Identity is: 000001
If OK, hit return, if you prefer a different Identity, type it here: 000001


Murano Example Smart Lightbulb Device Simulator booting…
Product Id:
Device Identity: 000001
Product Unique Host: .m2.exosite.com

get stored CIK from non-volatile memory
Unable to read a stored CIK: [Errno 2] No such file or directory: '_000001_cik’
try to activate
Exception: [Errno 11004] getaddrinfo failed
starting main loop
Exception: must be str, not NoneType
Connection: Not Connected, Run Time: 2, Temperature: 70.0 F, Humidity: 50.0 %, Light State: 0

Exception: [WinError 10060] A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond
Connection: Not Connected, Run Time: 553, Temperature: 70.0 F, Humidity: 50.0 %, Light State: 0

Thanks
Reddy


#4

@aashrith

Hmm, the fact that your message includes your input and then the configuration print out in the next section appears to ignore that tells me that something really went wrong in the first lines of your code being run.

What version of python are you running?

-Martin


#5

Python 3.6.2 (v3.6.2:5fd33b5, Jul 8 2017, 04:14:34) [MSC v.1900 32 bit (Intel)]
on win32