eWON Data gaps if eWON off line

Following an earlier post about my Exosense importing “false zeros” from my eWON, I have upgraded the PLC programming linked to my eWON. If a sensor in my process is down for whatever reason, the PLC polling will now report the previous value rather than a zero.
This problem arose because of short term brief power cuts at my site.
Following this upgrade, I tested yesterday a “forced power cut” and at my end the problem is solved. The eWON is not recording any false zero values. However, I still see zeros in my ExoSense data.
Conclusion - it appears that if the eWON is off line, ExoSense populates the database with zero’s ?
From time to time, connectivity is bound to be lost - am I missing something in my ExoSense set up ?

Hello smithdj5!
Thank you again for reaching out to the Exosite Community!

I have a couple of questions for you just to make sure I have a clear understanding of the current issue you are running into:

  1. Which group or groups are these tags assigned to on the Flexy?
  2. When you performed a “forced power cut”, was this cutting power from the Flexy to the PLC, such that the Flexy is still reading/reporting tag data, or was the Flexy also cut off from power?

There aren’t any mechanisms in ExoSense which would automatically set a value to zero, so this is most likely happening somewhere earlier in the data stream. However, we will want to confirm this to be the case.

Something we can check right away are the ExoSense device logs. At the very least, we can confirm which values are making it through to the Application and give us a better idea of where the problem is.

In case you are unfamiliar, I will attach a screenshot that shows how to access those logs in the Application. If you run the test again and watch the logs for that period of time, you should see each individual payload with the data points included. If the tag values are zero, we know the problem is caused by something prior to the data reaching Exosense, and we can go from there.

Thank you,
Pat Shanks

1 Like

Hi Pat,
Sorry for slow reply. Here to answer your questions -

  1. All tags assigned to Group A or B
  2. Power cut was simultaneously to both Flexy and PLC [on same circuit] but not the actual sensors
    I just now did another “power cut” and watched the logs. Here is a screen shot -

    So, I cut power at 16:52 and turned back on at 17:00. Taking tag 23 (Energy Zone 2) as an example, it’s value at 16:52 was 11862.4 kWh but when the eWON and Flexy came back on line the reported value is zero. Strangely for Energy Zone 1 (tag 22) , it worked OK and didn’t get a zero.
    I’ve also been looking at data stored on the eWON and it looks like it is an eWON problem creating some zeros when power comes back on and it seems to be doing some strange stuff.
    So bottom line, Exosense is correctly recording what it gets from eWON. I’m going to raise a support ticket with my UK eWON distributor as they are normally good at solving these sort of weird problems.